Back to overview

Meraki Device and Uplink Check, Power School Status e-mail integration, and 1 other service are down

May 28, 2025 at 2:31am UTC
Affected services
Power School Status
Clever Status
Meraki Device and Uplink Check

Resolved
May 28, 2025 at 8:53am UTC

Meraki Device and Uplink Check recovered.

Updated
May 28, 2025 at 8:50am UTC

All Services Operational

Updated
May 28, 2025 at 4:25am UTC

Clever Status recovered.

Updated
May 28, 2025 at 4:23am UTC

All Services Operational

Updated
May 28, 2025 at 2:34am UTC

Power School Status e-mail integration recovered.

Created
May 28, 2025 at 2:31am UTC

All Power School Sevices are Operational