Back to overview

Some services are down

May 29, 2025 at 8:52pm UTC
Affected services
Go Guardian Status

Resolved
May 29, 2025 at 10:15pm UTC

Go Guardian is back to fully operational

Created
May 29, 2025 at 8:52pm UTC

This incident has been resolved