Back to overview
Downtime

Clever/Google Outage

Sep 18, 2025 at 3:54pm UTC
Affected services
Google Services Status
Clever Status

Resolved
Sep 19, 2025 at 6:36pm UTC

Clever has cleared there monitoring of Google SSO. They gave the all clear

Updated
Sep 19, 2025 at 12:52pm UTC

Clever is still actively monitoring the situation even after google gave the all clear

Updated
Sep 18, 2025 at 8:03pm UTC

Google has cleared there Outage / Clever outage remains

Created
Sep 18, 2025 at 3:54pm UTC

Clever Incident - Google Outage preventing some Logins to Clever - 18 September 2025