Back to overview
Degraded
Status Notification From I-ready
Nov 03 at 01:16pm CST
Affected services
I-ready Status
Resolved
Nov 04 at 02:59pm CST
[Monitoring]
Operational
A fix has been released, and Brigance Password Reset functionality has been restored. We apologize for any inconvenience this may have caused and appreciate your patience.
Affected services
Created
Nov 03 at 01:16pm CST
Current Status: Degraded Performance
Started: November 3, 2025 2:06PM EST
Resolved:
Affected i-Ready Feature: i-Ready - General
Update:
We are currently investigating error messages impacting students. Our team is actively working to identify the cause and will share updates as soon as more information is available.
Affected services