Back to overview
Degraded

Status Update From Clever

Nov 4, 2025 at 6:12pm UTC
Affected services
Clever Status

Resolved
Nov 5, 2025 at 6:44pm UTC

Incident resolved
This incident has been resolved.

Created
Nov 4, 2025 at 6:12pm UTC

Chromebook Login Issues
New incident: Investigating
There is a widespread issue involving Google that is currently impacting Chromebook logins, including Badges into Chromebooks. We are monitoring the issue and will provide status updates as they become available.