Back to overview
Degraded
Go Guardian Status Update
Nov 04 at 12:14pm CST
Affected services
Go Guardian Status
Resolved
Nov 04 at 12:41pm CST
Incident resolved
Update: Google has indicated that the incident affecting Chromebook logins has been fully resolved.
https://support.cloud.google.com/portal/system-status?product=WORKSPACE
Thank you for your patience and understanding.
Affected services
Created
Nov 04 at 12:14pm CST
GoGuardian Incident - Google is expereicning issues with Chromebook logins - 4 November 2025
Affected services